Автор Тема: Проблемма с кодировкой?  (Прочитано 33105 раз)

viktor

  • Гость
Re: Проблемма с кодировкой?
« Ответ #15 : Июня 13, 2012, 12:05:49 pm »
Не помогло. Может что-то не так делаю?

Мои действия:

1. Взял новый js_scripts.js из архива скачанного с этого форума
2. Открыл в Notepad++
3. Не выделяя текста, выбрал пункт меню "кодировка" Преобразовать в UTF-8(без BOM)
4. Сохранил файл на диске
5. Удалил js_scripts.js на сервере.
(кстати, после удаления этого файла с сервера, зашел на сайт магазина, скрипт работает и с теми-же проблемами что и при наличии
файла. Такое ощущение что файл не участвует в работе скрипта?)
6. Перезалил новый файл. Но результат все тот-же

 Хотелось бы знать, может быть следует все-же наладить кодировку win1251? Что надежнее? Чтобы сделать правильный выбор до
кропотливой работы по внесению товара.)

Оффлайн Dias

  • Пользователь
  • **
  • Сообщений: 75
    • Просмотр профиля
Re: Проблемма с кодировкой?
« Ответ #16 : Июня 13, 2012, 12:26:33 pm »
Удалите всё содержимое Ваш_сайт/core/cache. Очистите кэш браузера. Перепроверьте файл js_scripts.js, откройте еще раз его с помощью Notepad++ и в разделе "Кодировки" отметка должна быть напротив Кодировать в UTF-8(без BOM).

viktor

  • Гость
Re: Проблемма с кодировкой?
« Ответ #17 : Июня 13, 2012, 01:01:33 pm »
Сделал все как вы написали.

В папке сайт/core/cache ничего не обнаружил. Файл js_scripts.js перепроверил, отметка напротив win1251(без BOM). Кэш браузера
очистил. Увы мне( Все то-же. Перезалью все целиком сначала в кодировке win1251, затем еще раз в UTF-8. Если не поможет, придется
искать другой хостинг. Правд пока ns обновят... Снова два дня коту под хвост. А не хочется) Может кто посоветует недорогой
хостинг на котором все работает?

Оффлайн Dias

  • Пользователь
  • **
  • Сообщений: 75
    • Просмотр профиля
Re: Проблемма с кодировкой?
« Ответ #18 : Июня 13, 2012, 01:20:04 pm »
Скорее всего Вы невнимательно преобразовываете кодировку, так как файл на сервере до сих пор сейчас в ANSI.

Открываете файл http://maslo.biz.ua/core/js/js_scripts.js с помощью Notepad++, затем выбираете Кодировки-> Преобразовать в UTF-8 без BOM и нажимаете Файл->Сохранить. Заменяете соответствующий файл на сервере.

viktor

  • Гость
Re: Проблемма с кодировкой?
« Ответ #19 : Июня 13, 2012, 02:07:55 pm »
Перекодирую-то я все верно) Только вот почему-то хост меняет кодировку на ANSI. Если открыть файл с помощью Notepad++ прямо
с сайта - то да, кодировка ANSI. А если его сначала загрузить, потом открыть) - UTF-8 без BOM.
Меня терзают смутные сомнения. после многократной переустановки скрипта я мог при создании базы MySQL указать в ее
настройках кодировку default) Может быть дело в этом?

Для достоверности высылаю перекодированный файл с диска. Если вы можете, скачайте файл с сайта а после откройте в Notepad++

[вложение удалено администратором]

Оффлайн Dias

  • Пользователь
  • **
  • Сообщений: 75
    • Просмотр профиля
Re: Проблемма с кодировкой?
« Ответ #20 : Июня 13, 2012, 02:24:38 pm »
Написал в личные сообщения.

viktor

  • Гость
Re: Проблемма с кодировкой?
« Ответ #21 : Июня 13, 2012, 06:40:26 pm »
DirectoryIndex index.php
   AddDefaultCharset windows-1251
   AddCharset windows-1251 .php
        Options -Indexes

Это значит что все нужно удалить и переустановить из архива?

Кстати, пробовал открыть .htaccess прямо на сервере, получил: "Ошибка:    Конвертация в 'UTF-8' не поддерживается на стороне
 сервера" Буду звонить в службу поддержки

viktor

  • Гость
Re: Проблемма с кодировкой?
« Ответ #22 : Июня 13, 2012, 08:16:20 pm »
Все оказалось просто и банально))) При переходе на новый хост ns имена не обновились) А я и не догадался проверить(
Большое всем спасибо за участие! Надеюсь, после обновления имен все заработает) После запуска скрипта отпишусь.


viktor

  • Гость
Re: Проблемма с кодировкой?
« Ответ #23 : Июня 14, 2012, 05:25:42 pm »
Перекодировка файла js_scripts.js с помощью Notepad++ решила все вопросы) Скрипт работает, за что спасибо всем
участвовавшим в решении данной проблемы)

dimadimadim

  • Гость
Re: Проблемма с кодировкой?
« Ответ #24 : Ноября 07, 2012, 01:58:48 am »
Скачал Shop-Script Lego Edition SP 6.1
Установлен на Денвере

(Всё в одной заметке Evernote https://www.evernote.com/shard/s99/sh/c548eac8-af79-46bf-adec-724c2993556f/63fd6dc85519ec334f7d41b4d9cc3cae?noteKey=63fd6dc85519ec334f7d41b4d9cc3cae&noteGuid=c548eac8-af79-46bf-adec-724c2993556f)

После шагов установки, включения тестового наполнения сайта в некоторых блоках появились вместо «нормальных», символы со знаками вопросов

https://www.evernote.com/shard/s99/sh/c548eac8-af79-46bf-adec-724c2993556f/63fd6dc85519ec334f7d41b4d9cc3cae/res/0f164487-a570-4f31-8147-b722d662bbe5/plrz8081.bmp?resizeSmall&width=832
в правой части пользовательского меню

https://www.evernote.com/shard/s99/sh/c548eac8-af79-46bf-adec-724c2993556f/63fd6dc85519ec334f7d41b4d9cc3cae/res/0efff0fa-bb10-4a02-b2b2-ef8aa9323d41/oi3s08ul.bmp?resizeSmall&width=832
https://www.evernote.com/shard/s99/sh/c548eac8-af79-46bf-adec-724c2993556f/63fd6dc85519ec334f7d41b4d9cc3cae/res/44b3448d-8d3b-44dd-aaf7-14762a6840f3/xi0p5j2b.bmp?resizeSmall&width=832
В левом выпадающем меню, в контенте редактора текста, в контенте полей ввода, а также в других неизменяемых полях изменяемых данных.

https://www.evernote.com/shard/s99/sh/c548eac8-af79-46bf-adec-724c2993556f/63fd6dc85519ec334f7d41b4d9cc3cae/res/063e38da-b456-4987-9694-0f108d20c2c2/qnqw4us9.bmp?resizeSmall&width=832
На главной странице, где в редакторе текста были «вопросы», контент выглядит верно, без знаков вопросов.

На некоторых других страницах появляются:
https://www.evernote.com/shard/s99/sh/c548eac8-af79-46bf-adec-724c2993556f/63fd6dc85519ec334f7d41b4d9cc3cae/res/1905be39-bf4a-48e8-9774-6f3cf93724fe/flt1y2n6.bmp?resizeSmall&width=832

Установлен на Денвере

Основную кодировку менял httpd.conf
 Z -> usr -> local -> apache -> conf -> httpd.conf
 #AddDefaultCharset utf-8
Но во «внутреннем» .htaccess и так уже эта строка прописана

core\js\js_scripts.js
Уже был преобразован в UTF-8 without BOM

 

в phpMyAdmin
https://www.evernote.com/shard/s99/sh/c548eac8-af79-46bf-adec-724c2993556f/63fd6dc85519ec334f7d41b4d9cc3cae/res/820eb803-19cb-471f-9c56-3d1442f347f9/1vimzv1r.bmp?resizeSmall&width=832

Только установил, поиском по форуму пользовался. В чём может быть проблема? Если не там запостил, пожалуйста, перенесите.

Andrey

  • Гость
Re: Проблемма с кодировкой?
« Ответ #25 : Февраля 22, 2013, 12:56:56 am »
Идентичная проблема, хотелось бы всё таки узнать как исправить

Andrey

  • Гость
Re: Проблемма с кодировкой?
« Ответ #26 : Февраля 22, 2013, 01:18:04 am »
спасибо за оперативность :)

Оффлайн Dordgic

  • Случайный Прохожий
  • *
  • Сообщений: 1
    • Просмотр профиля
Проблемма с кодировкой
« Ответ #27 : Декабря 16, 2015, 02:20:35 am »
ФАК читал, В .htacces AddDefaultCharset win-1251 В mysql_query"SET NAMES 'utf-8'";
Проблема в следующем в Opere и Firefoxе отображается русский так Форум
В IE с кодировкой проблем нет. Что надо сделать чтобы и в Opere понятно отображалось?

Оффлайн RedLine

  • LegoSP developer
  • Пользователь
  • *****
  • Сообщений: 44
    • Просмотр профиля
Re: Проблемма с кодировкой?
« Ответ #28 : Декабря 16, 2015, 10:18:58 am »
Dordgic, удалите из .htacces AddDefaultCharset win-1251  и вставьте
AddDefaultCharset utf-8
AddCharset utf-8 *
        <IfModule mod_charset.c>
          CharsetSourceEnc utf-8
          CharsetDefault utf-8
        </IfModule>
Уточните, каким образом импортирована база, производилась ли ее конвертация в другую кодировку?