Автор Тема: Проблемма с кодировкой?  (Прочитано 33110 раз)

viktor

  • Гость
Проблемма с кодировкой?
« : Июня 12, 2012, 08:34:20 pm »
  Установил Lego SP 5.0.2 на платный хостинг http://hostservice.ua В установщике из двух вариантов указал KOI-8. В
итоге не работает форма заказа и регистрации покупателя. Если вводить русскими буквами, выбрасывает внизу знаки
 вопроса "����������, ������� ������ ������� � ��������� �����!"  Если латиницей, то все
 ОК. Форма не заполняется, заказ не проходит. Файл с ошибками пуст. Менял кодировку файла js_scripts.js, ничего
 не дало. Кто знает в чем дело, пожалуйста подскажите.

viktor

  • Гость
Re: Проблемма с кодировкой?
« Ответ #1 : Июня 13, 2012, 09:36:28 am »
УПС), хотел написать utf-8))))
win1251 ставил. Браузеры, и мозила и эксплорер, на обоих моих компах показывают кракозябры, пока в них принудительно не переведешь
кодировку. И то, до перехода на следующую страницу, где снова приходится менять кодировку) Это что, у всех моих клиентов
будет такая проблема с посещением магазина?)
Пожалуйста помогите настроить чтоб работало, а я уж в долгу не останусь.
« Последнее редактирование: Июня 13, 2012, 10:50:40 am от viktor »

viktor

  • Гость
Re: Проблемма с кодировкой?
« Ответ #2 : Июня 13, 2012, 10:10:52 am »
1. Lego SP 5.0.2

2. Данные сервера: phpMyAdmin  и MySQL, Ruby, Rails, Passenger.
PHP версии 5.3 (PHP 5.2 по запросу).
Поддерживаются последние стабильные версии ПО.
Подробнее: http://hostservice.ua/hosting/
Никак не настраивал. Сделал только базу MySQL. (кстати, после установки скрипта размер базы нулевой, это нормально?)

3. www.maslo.biz.ua

4. Проблему с кодировкой описал выше)

Сейчас кодировка utf-8. Может переставить на win1251 и тогда заглянете?
« Последнее редактирование: Июня 13, 2012, 10:50:04 am от viktor »

viktor

  • Гость
Re: Проблемма с кодировкой?
« Ответ #3 : Июня 13, 2012, 10:17:56 am »
Кстати, права я настраивал вручную вот по этой статье:
http://legosp.blogspot.com/2011/05/lego-sp.html

viktor

  • Гость
Re: Проблемма с кодировкой?
« Ответ #4 : Июня 13, 2012, 10:56:20 am »
А вы форму заказа пробовали заполнить? (русскими  буквами не ругается?)

Оффлайн Dias

  • Пользователь
  • **
  • Сообщений: 75
    • Просмотр профиля
Re: Проблемма с кодировкой?
« Ответ #5 : Июня 13, 2012, 11:07:42 am »
У Вас сейчас сайт в utf-8, а кодировка js_scripts.js в ANSI. Попробуйте еще раз внимательно изменить кодировку на utf-8(без BOM).

viktor

  • Гость
Re: Проблемма с кодировкой?
« Ответ #6 : Июня 13, 2012, 11:18:14 am »
Какой прогой лучше изменить кодировку?  И что такое (без ВОМ)

Вот снимок экрана в Хроме



[вложение удалено администратором]

Оффлайн Dias

  • Пользователь
  • **
  • Сообщений: 75
    • Просмотр профиля
Re: Проблемма с кодировкой?
« Ответ #7 : Июня 13, 2012, 11:21:42 am »
Какой прогой лучше изменить кодировку?  И что такое (без ВОМ)

Вот снимок экрана в Хроме

Программа Notepad++. Кодировка -> Преобразовать в UTF-8(без BOM)

viktor

  • Гость
Re: Проблемма с кодировкой?
« Ответ #8 : Июня 13, 2012, 12:05:49 pm »
Не помогло. Может что-то не так делаю?

Мои действия:

1. Взял новый js_scripts.js из архива скачанного с этого форума
2. Открыл в Notepad++
3. Не выделяя текста, выбрал пункт меню "кодировка" Преобразовать в UTF-8(без BOM)
4. Сохранил файл на диске
5. Удалил js_scripts.js на сервере.
(кстати, после удаления этого файла с сервера, зашел на сайт магазина, скрипт работает и с теми-же проблемами что и при наличии
файла. Такое ощущение что файл не участвует в работе скрипта?)
6. Перезалил новый файл. Но результат все тот-же

 Хотелось бы знать, может быть следует все-же наладить кодировку win1251? Что надежнее? Чтобы сделать правильный выбор до
кропотливой работы по внесению товара.)

Оффлайн Dias

  • Пользователь
  • **
  • Сообщений: 75
    • Просмотр профиля
Re: Проблемма с кодировкой?
« Ответ #9 : Июня 13, 2012, 12:26:33 pm »
Удалите всё содержимое Ваш_сайт/core/cache. Очистите кэш браузера. Перепроверьте файл js_scripts.js, откройте еще раз его с помощью Notepad++ и в разделе "Кодировки" отметка должна быть напротив Кодировать в UTF-8(без BOM).

viktor

  • Гость
Re: Проблемма с кодировкой?
« Ответ #10 : Июня 13, 2012, 01:01:33 pm »
Сделал все как вы написали.

В папке сайт/core/cache ничего не обнаружил. Файл js_scripts.js перепроверил, отметка напротив win1251(без BOM). Кэш браузера
очистил. Увы мне( Все то-же. Перезалью все целиком сначала в кодировке win1251, затем еще раз в UTF-8. Если не поможет, придется
искать другой хостинг. Правд пока ns обновят... Снова два дня коту под хвост. А не хочется) Может кто посоветует недорогой
хостинг на котором все работает?

Оффлайн Dias

  • Пользователь
  • **
  • Сообщений: 75
    • Просмотр профиля
Re: Проблемма с кодировкой?
« Ответ #11 : Июня 13, 2012, 01:20:04 pm »
Скорее всего Вы невнимательно преобразовываете кодировку, так как файл на сервере до сих пор сейчас в ANSI.

Открываете файл http://maslo.biz.ua/core/js/js_scripts.js с помощью Notepad++, затем выбираете Кодировки-> Преобразовать в UTF-8 без BOM и нажимаете Файл->Сохранить. Заменяете соответствующий файл на сервере.

viktor

  • Гость
Re: Проблемма с кодировкой?
« Ответ #12 : Июня 13, 2012, 02:07:55 pm »
Перекодирую-то я все верно) Только вот почему-то хост меняет кодировку на ANSI. Если открыть файл с помощью Notepad++ прямо
с сайта - то да, кодировка ANSI. А если его сначала загрузить, потом открыть) - UTF-8 без BOM.
Меня терзают смутные сомнения. после многократной переустановки скрипта я мог при создании базы MySQL указать в ее
настройках кодировку default) Может быть дело в этом?

Для достоверности высылаю перекодированный файл с диска. Если вы можете, скачайте файл с сайта а после откройте в Notepad++

[вложение удалено администратором]

Оффлайн Dias

  • Пользователь
  • **
  • Сообщений: 75
    • Просмотр профиля
Re: Проблемма с кодировкой?
« Ответ #13 : Июня 13, 2012, 02:24:38 pm »
Написал в личные сообщения.

viktor

  • Гость
Re: Проблемма с кодировкой?
« Ответ #14 : Июня 13, 2012, 06:40:26 pm »
DirectoryIndex index.php
   AddDefaultCharset windows-1251
   AddCharset windows-1251 .php
        Options -Indexes

Это значит что все нужно удалить и переустановить из архива?

Кстати, пробовал открыть .htaccess прямо на сервере, получил: "Ошибка:    Конвертация в 'UTF-8' не поддерживается на стороне
 сервера" Буду звонить в службу поддержки